Camarosource Forum

 
  • Home
  • Register
  • Advertise
  • Members
  • New Posts
  • Contact Us
  • Store
  • Photo's
  • Reviews
  • Classifieds
  • Camaro Info Database
Welcome to CamaroSource.ca
camarosource
Welcome Guest,

You are currently viewing our forum as a Guest, which gives you limited access to view most posts. JOIN our community, and gain full access to not only the message board, but our other many features of the site such as Classifieds, Camaro Gallery, and our Product Reviews as well as other features that will become active at a later date.

Registering with us FREE, fast and a very simple step, join the Camarosource.ca community today!

Already a member? Login to gain full access Now!

Thanks for stopping by.
 
Username

Password

Log me on automatically

choke/fast idle issue

Post questions and answers about your engine problems.. What is this ticking sound I hear while starting? Engine not turning over? Problems with your battery... alternator? Find out here.

Moderator: Moderators

 
Post
Nates Z28s
Posted: Sun Nov 29, 2009 12:51 pm
Minimum of 80 Posts
Minimum of 80 Posts
Joined: Mon Apr 10, 2006 1:40 pm
Location: Gilbert, Arizona
Posts: 81
Where Did You Hear Of Camarosource.ca?: searching random Camaro stuff
Hey All,

I'm having an issue with the choke light and fast idle on my 84 Z. I took it to a show last weekend and after starting it up warm the choke light came on. It stayed on until I gave it a rev and then it shut off. The next day I started it cold and the fast idle kicked on pretty high and would not go down until the car was at normal running temp and the choke light was on as well. Once the fast idle kicked down the choke light went off and it was running fine. I've never seen the choke light come on before and ever since I moved out to the warmer climate and had the carb rebuilt the fast idle hasn't kicked in til now. I'm thinking the choke wasn't working either. I like it better the way it was before.

What I'm wondering is if I disconnect the electronic choke if that will make the car run like it was and eliminate the fast idle. Do you think it would cause any other problems with the car other then the initial start up when it's cold? Any thoughts?

Thanks,

Nate
Nate

2003 Chevrolet S10: 100,000 miles, 4 cyl, 5 speed work truck, nothing special.

1984 Camaro Z28: High Output 305, 5 speed, 50,000 miles, Dark Goldwing Metallic (Brown)/Tan

1982 Camaro Z28: 350, 4 speed, set up for drag racing, Black

and many rental vehicles
 

 

Return to Engine / Fuel / Starting / Charging System

Who is online

Users browsing this forum: No registered users and 2 guests

cron