Camarosource Forum

 
  • Home
  • Register
  • Advertise
  • Members
  • New Posts
  • Contact Us
  • Store
  • Photo's
  • Reviews
  • Classifieds
  • Camaro Info Database
Welcome to CamaroSource.ca
camarosource
Welcome Guest,

You are currently viewing our forum as a Guest, which gives you limited access to view most posts. JOIN our community, and gain full access to not only the message board, but our other many features of the site such as Classifieds, Camaro Gallery, and our Product Reviews as well as other features that will become active at a later date.

Registering with us FREE, fast and a very simple step, join the Camarosource.ca community today!

Already a member? Login to gain full access Now!

Thanks for stopping by.
 
Username

Password

Log me on automatically

Water leaking from top of water pump ?

Post questions and answers about your engine problems.. What is this ticking sound I hear while starting? Engine not turning over? Problems with your battery... alternator? Find out here.

Moderator: Moderators

 
Post
TCA217
Posted: Fri Feb 05, 2010 12:45 am
Minimum of 60 Posts
Minimum of 60 Posts
Joined: Mon Feb 04, 2008 12:51 am
Location: Lakewood, Calif
Posts: 61
Where Did You Hear Of Camarosource.ca?: searching Google
Hello board, was wondering if anyone else has had this problem. My 97 RS with the 3.8 in it seems to be leaking water from the TOP of the water pump. Could this be the water pump or do you think it is possibly the intake manifold. Car has 115,xxx miles on it. Any tricks to make it easier to take the water pump or intake off? As you all know these 3.8 V6 motors are a real pain to work on. Thanks in advace, ................. TIM
Have a 1967 RS totally restored. 327 with a powerglide and A/C 91,000 miles
Just got a 30th anniversay 1997 Camaro with 3.8 V6 and a 5 speed 104,000 miles
 

Post
ins0mnia24
Posted: Fri Feb 05, 2010 5:31 am
Minimum of 4000 Posts
Minimum of 4000 Posts
User avatar
Joined: Sat May 28, 2005 8:13 am
Location: New Jersey
Posts: 4576
Where Did You Hear Of Camarosource.ca?: Boobs
You should really clean up that entire area so you can see where it is leaking since there is a few hose there..
If it isn't coming from the hoses you want to check and see if the coolant is pooling on top of the engine block..

I forget where the weep hole is on the 3.8 water pump some 4th gens are above the pulley others are below the pulley so you will want to check that also...

Due to the area it sounds like you have an upper or lower intake manifold gasket leak..

On 3.8's the only thing you have to remember is you have to remove the thermostat housing in order to gain access to one of the intake bolts..
Image
 

Post
TCA217
Posted: Sat Feb 06, 2010 7:38 pm
Minimum of 60 Posts
Minimum of 60 Posts
Joined: Mon Feb 04, 2008 12:51 am
Location: Lakewood, Calif
Posts: 61
Where Did You Hear Of Camarosource.ca?: searching Google
Thanks for the info. I did blow off the top of the motor where the intake meets the block. A friend of mine who knows these motors came by and helped me look. We found small puddles of water on top where the intake meets the block and his conclusion is that the leak is coming from there, not the pump or hoses. We could actually see small bubbles coming out so I guess it is time to do a top end reseal of the the gaskets. Not looking forward to the job but I guess you got to do what ever it is to get it done, LOL. Thanks again for the info. As always the help, is appreciated. TIM
Have a 1967 RS totally restored. 327 with a powerglide and A/C 91,000 miles
Just got a 30th anniversay 1997 Camaro with 3.8 V6 and a 5 speed 104,000 miles
 

Post
ins0mnia24
Posted: Sun Feb 07, 2010 7:31 am
Minimum of 4000 Posts
Minimum of 4000 Posts
User avatar
Joined: Sat May 28, 2005 8:13 am
Location: New Jersey
Posts: 4576
Where Did You Hear Of Camarosource.ca?: Boobs
Yeh I knew that is what it sounded like..
Another thing to keep in mind If you are using Dex Cool make sure you use the real OEM GM Gasket which is approved to be used with Dex Cool..
If you are not using Dex Cool dont worry about it..
Image
 

Post
TCA217
Posted: Mon Feb 08, 2010 6:39 am
Minimum of 60 Posts
Minimum of 60 Posts
Joined: Mon Feb 04, 2008 12:51 am
Location: Lakewood, Calif
Posts: 61
Where Did You Hear Of Camarosource.ca?: searching Google
Once again, thank you. Will be going back with good 'ol Prestone. Thanks again, ............TIM
Have a 1967 RS totally restored. 327 with a powerglide and A/C 91,000 miles
Just got a 30th anniversay 1997 Camaro with 3.8 V6 and a 5 speed 104,000 miles
 


 

Return to Engine / Fuel / Starting / Charging System

Who is online

Users browsing this forum: No registered users and 5 guests

cron