Camarosource Forum

 
  • Home
  • Register
  • Advertise
  • Members
  • New Posts
  • Contact Us
  • Store
  • Photo's
  • Reviews
  • Classifieds
  • Camaro Info Database
Welcome to CamaroSource.ca
camarosource
Welcome Guest,

You are currently viewing our forum as a Guest, which gives you limited access to view most posts. JOIN our community, and gain full access to not only the message board, but our other many features of the site such as Classifieds, Camaro Gallery, and our Product Reviews as well as other features that will become active at a later date.

Registering with us FREE, fast and a very simple step, join the Camarosource.ca community today!

Already a member? Login to gain full access Now!

Thanks for stopping by.
 
Username

Password

Log me on automatically

speedometer malfunction

Post questions and answers about various interior related topics. Seat problems? Seat Belts, carpeting... Etc

Moderator: Moderators

 
Post
bcfipp
Posted: Sun Jul 27, 2008 5:47 pm
Joined: Sun Jul 27, 2008 5:00 pm
Posts: 1
Where Did You Hear Of Camarosource.ca?: google
I have a 1991 z28. I replaced the speed sensor. The speedometer says my mph is 110 at idle. When i am moving it goes past 110? I was wondering what could be the problem
 

Post
95camaro85ta
Posted: Tue Jul 29, 2008 1:48 pm
Minimum of 400 Posts
Minimum of 400 Posts
Joined: Wed May 28, 2008 8:28 pm
Location: iowa
Posts: 544
Where Did You Hear Of Camarosource.ca?: saw it on google
try dissconecting the battery and remove the power to speed sensor and plug it back in reconnect the battery
88 camaro iroc z TBI 350-auto
85 trans am- parts car 350-auto
85 trans am- 355 sbc, wc t5...damn near everything new...
97 k2500 350 vortec 5 speed
 


 

Return to Interior

Who is online

Users browsing this forum: No registered users and 1 guest

cron